[ CVE-2026-83525 · Published 28 Oct 2026 ]
Vulnerability in Apache Software Foundation Apache Kafka
[ Description ]Official description
Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service (controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions. Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue. Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.
[ Fixes ]Fixes and patches
No fix or interim patch is linked from our sources yet. Check the vendor references below and limit exposure of affected systems until a fix is available.
[ Advisories ]Government CERT advisories
-
CERT-FRCERTFR-2026-AVI-1415
Multiple vulnerabilities in Apache Kafka Translated from French
Multiple vulnerabilities have been discovered in Apache Kafka. Some of them allow an attacker to cause remote denial of service, a breach of data confidentiality and a breach of data integrity.
-
BSI CERT-BundWID-SEC-2026-4221
Apache Kafka: Multiple vulnerabilities Translated from German