[ CVE-2026-116688 · Published 27 Oct 2026 ]
CKEditor: Cross-site scripting (XSS) in the engine package
CVSS 8.1
EPSS <1%Fix available
[ Description ]Official description
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 45.0.0 until 47.7.4 and 48.5.1, the engine uses a vulnerable es-toolkit version whose prototype-pollution behavior can be reached while CKEditor processes incoming style attribute values. Crafted editor content can thereby cause unauthorized JavaScript execution in the browser. This issue is fixed in versions 47.7.4 and 48.5.1.
[ Fixes ]Fixes and patches
- ckeditor5 47.7.4Fixed version · GitHub Advisories · npm package ckeditor5: upgrade to 47.7.4 or later (affected >= 45.0.0, < 47.7.4)
- @ckeditor/ckeditor5-engine 47.7.4Fixed version · GitHub Advisories · npm package @ckeditor/ckeditor5-engine: upgrade to 47.7.4 or later (affected >= 45.0.0, < 47.7.4)
- ckeditor5 48.5.1Fixed version · GitHub Advisories · npm package ckeditor5: upgrade to 48.5.1 or later (affected >= 48.0.0, < 48.5.1)
- @ckeditor/ckeditor5-engine 48.5.1Fixed version · GitHub Advisories · npm package @ckeditor/ckeditor5-engine: upgrade to 48.5.1 or later (affected >= 48.0.0, < 48.5.1)
[ Packages ]Affected open-source packages
- ckeditor5 npmAffected >= 45.0.0, < 47.7.4 · fixed in 47.7.4 · GHSA-rh54-vffm-5fvp
- @ckeditor/ckeditor5-engine npmAffected >= 45.0.0, < 47.7.4 · fixed in 47.7.4 · GHSA-rh54-vffm-5fvp
- ckeditor5 npmAffected >= 48.0.0, < 48.5.1 · fixed in 48.5.1 · GHSA-rh54-vffm-5fvp
- @ckeditor/ckeditor5-engine npmAffected >= 48.0.0, < 48.5.1 · fixed in 48.5.1 · GHSA-rh54-vffm-5fvp
[ References ]References
- github.com/ckeditor/ckeditor5/commit/4d9c5bb34f63cd956d15ccafbe584e14280c86a0
- github.com/ckeditor/ckeditor5/commit/a750e38635db6a18c5b11599c09f4fd702850423
- github.com/ckeditor/ckeditor5/releases/tag/v47.7.4
- github.com/ckeditor/ckeditor5/releases/tag/v48.5.1
- github.com/ckeditor/ckeditor5/security/advisories/GHSA-rh54-vffm-5fvp