[ CVE-2026-116593 · Published 28 Oct 2026 ]
Vulnerability in Apache Software Foundation Apache Kafka
[ Description ]Official description
Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations. Apache Kafka Connect also support Configuration Providers which enable to hide the values of sensitive configuration and only resolve them at runtime. An attacker with access to the validate endpoint can use it to resolve and return plaintext values via any of the configuration providers installed on a Connect worker. Users are recommended to upgrade to version 4.2.2, 4.3.2, 4.4.0 or above, which fix this issue.
[ Fixes ]Fixes and patches
No fix or interim patch is linked from our sources yet. Check the vendor references below and limit exposure of affected systems until a fix is available.
[ Advisories ]Government CERT advisories
-
CERT-FRCERTFR-2026-AVI-1415
Multiple vulnerabilities in Apache Kafka Translated from French
Multiple vulnerabilities have been discovered in Apache Kafka. Some of them allow an attacker to cause remote denial of service, a breach of data confidentiality and a breach of data integrity.
-
BSI CERT-BundWID-SEC-2026-4221
Apache Kafka: Multiple vulnerabilities Translated from German