[ CVE-2026-115918 · Published 26 Oct 2026 ]
vLLM: Responses API bypasses trust_request_chat_template for chat_template_kwargs
CVSS 6.5
EPSS <1%1 agency advisoryFix available
[ Description ]Official description
vLLM is an inference and serving engine for large language models. From 0.16.0 until 0.32.0, the /v1/responses endpoint allows an authenticated caller to place an attacker-controlled template in chat_template_kwargs[chat_template] when no server template is configured. ChatParams.get_apply_chat_template_kwargs() preserves that value without enforcing trust_request_chat_template, so the request can bypass the intended trust policy and cause CPU or memory exhaustion through Jinja rendering. This issue is fixed in version 0.32.0.
[ Fixes ]Fixes and patches
- vllm 0.32.0Fixed version · GitHub Advisories · pip package vllm: upgrade to 0.32.0 or later (affected >= 0.16.0, < 0.32.0)
- Patch on github.comVendor patch or bulletin · NVD · Reference tagged 'Patch' by NVD
- Patch on github.comVendor patch or bulletin · NVD · Reference tagged 'Patch' by NVD
- Patch on github.comVendor patch or bulletin · NVD · Reference tagged 'Patch' by NVD
[ Advisories ]Government CERT advisories
-
BSI CERT-BundWID-SEC-2026-4051
vllm: Multiple vulnerabilities Translated from German
[ Packages ]Affected open-source packages
- vllm pipAffected >= 0.16.0, < 0.32.0 · fixed in 0.32.0 · GHSA-x567-49g5-p4cf