[ CVE-2026-115915 · Published 26 Oct 2026 ]

vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE

CVSS 9.8 EPSS <1%Fix available

[ Why it matters ]Priority signals

  • Critical severity: CVSS 9.8

[ Description ]Official description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

[ Fixes ]Fixes and patches

  • vllm 0.32.0Fixed version · GitHub Advisories · pip package vllm: upgrade to 0.32.0 or later (affected < 0.32.0)
  • Patch on github.comVendor patch or bulletin · NVD · Reference tagged 'Patch' by NVD
  • Patch on github.comVendor patch or bulletin · NVD · Reference tagged 'Patch' by NVD
  • Patch on github.comVendor patch or bulletin · NVD · Reference tagged 'Patch' by NVD

[ Packages ]Affected open-source packages