[ CVE-2026-115914 · Published 26 Oct 2026 ]
vLLM DeepSeek-OCR image processing vulnerable to denial of service
CVSS 6.5
EPSS <1%1 agency advisoryFix available
[ Description ]Official description
vLLM is an inference and serving engine for large language models. From 0.11.1 until 0.32.0, the DeepSeek-OCR, DeepSeek-OCR-2, and Unlimited-OCR image path allows a remote client that can reach the OpenAI-compatible API to submit a legal image whose normalized pixels sum to zero when that image is alone in its per-step encoder batch. _parse_and_validate_image_input returns no embedding, embed_multimodal propagates that value, and sanity_check_mm_encoder_outputs triggers a fatal assertion that shuts down the engine for all users. This issue is fixed in version 0.32.0.
[ Fixes ]Fixes and patches
- vllm 0.32.0Fixed version · GitHub Advisories · pip package vllm: upgrade to 0.32.0 or later (affected >= 0.11.1, < 0.32.0)
- Patch on github.comVendor patch or bulletin · NVD · Reference tagged 'Patch' by NVD
- Patch on github.comVendor patch or bulletin · NVD · Reference tagged 'Patch' by NVD
- Patch on github.comVendor patch or bulletin · NVD · Reference tagged 'Patch' by NVD
[ Advisories ]Government CERT advisories
-
BSI CERT-BundWID-SEC-2026-4051
vllm: Multiple vulnerabilities Translated from German
[ Packages ]Affected open-source packages
- vllm pipAffected >= 0.11.1, < 0.32.0 · fixed in 0.32.0 · GHSA-gq5q-89c7-vhvx