[ CVE-2026-109518 · Published 4 Nov 2026 ]

Vulnerability in Debian APT

CVSS 7.7 Fix available

[ Why it matters ]Priority signals

  • Interim mitigation published by PrivacySafe

[ Description ]Official description

On Debian, Ubuntu, and derivative Linux distributions, an on-path attacker who can manipulate the HTTP traffic (including a malicious mirror or proxy) between an APT client and an archive server triggered by a package install can trick the client into installing an attacker-controlled unverified package and achieve remote code execution with root privileges. The vulnerability is caused by the reuse of hard links and requires the client to follow redirects and retry the download of package files. It requires the client to have a non-zero Acquire::Retries configuration setting; the value 3 is the default starting with Debian 12 (bookworm) and Ubuntu 22.04 LTS (Jammy Jellyfish), so older releases are unaffected in a default configuration

[ Fixes ]Fixes and patches

  • APT package downloadsInterim mitigation · PrivacySafe · Check, hunt, stopgap (`mitigate`) and rollback for Debian, Ubuntu and their derivatives: APT before the fixed release of its line (3.0.4, 2.6.2, 2.8.4 and others), when it follows redirects and retries downloads